Deploying a Cisco Data Center

Module 6: Configure VXLAN Routing

vxlan_evpn-10
  1. Configure Tenant VRFs for VXLAN Routing and associate to L3 VXLAN VNI.

    The configuration of these two Tenant VRFs, tenanat-a and tenant-b, introduces multitenancy.

POD-0-Leaf-:


        #Config Block 1

        conf
        vrf context tenant-a
            vni 10010
            rd auto
            address-family ipv4 unicast
                route-target both auto
                route-target both auto evpn

        vrf context tenant-b
            vni 20020
            rd auto
            address-family ipv4 unicast
                route-target both auto
                route-target both auto evpn
            exit
        end
    
  1. Configure the Tenant VRFs under your BGP process:

POD-0-Leaf-:


        #Config Block 2

        conf
        router bgp 65000
            vrf tenant-a
                address-family ipv4 unicast
                    advertise l2vpn evpn
            vrf tenant-b
                address-family ipv4 unicast
                    advertise l2vpn evpn
            exit
        end
    

3. Configure Overlay/L3 SVI for VXLAN Routing.

POD-0-Leaf-:


        #Config Block 3

        conf
        interface vlan 10
            vrf member tenant-a
            ip forward
            no shut
        interface vlan 20
            vrf member tenant-b
            ip forward
            no shut
        end
    

4. Configure Host SVI for VXLAN Routing.

POD-0-Leaf-:


        #Config Block 4

        conf
        fabric forwarding anycast-gateway-mac 0000.1234.5678
        interface vlan 11
            vrf member tenant-a
            ip address 10.0.11.1/24
            fabric forwarding mode anycast-gateway
            no shut
        interface vlan 12
            vrf member tenant-a
            ip address 10.0.12.1/24
            fabric forwarding mode anycast-gateway
            no shut
        interface vlan 21
            vrf member tenant-b
            ip address 20.0.21.1/24
            fabric forwarding mode anycast-gateway
            no shut
        interface vlan 22
            vrf member tenant-b
            ip address 20.0.22.1/24
            fabric forwarding mode anycast-gateway
            no shut
        end